Tag Archives: puppet-lint

Disable puppet-lint class inheriting from params class

I normally use Vim to edit Puppet modules and manifests codes. However, recently I just found out about Atom editor, and quite like it. Out of the box, Atom supports many programming languages by providing syntax highlight. There are hundreds of Packages available which provide more functionalities such as make Atom to behave like a Vi editor, support Puppet codes, etc.

As mentioned earlier, Atom provides syntax highlighting for various programming languages; well except Puppet. So we need to manually install a package that fills that requirement: language-puppet. I also suggest that you additionally install linter and linter-puppet packages.

By default puppet-lint (provided by linter-puppet package), will complain about the use of class inheriting because this feature is not compatible with Puppet 2.6.2 and earlier. However, in my case I’m using Puppet 3.8.1, and I really like class inheriting.

To disable that puppet-lint warning, you can just pass this option to the puppet-lint command line:

--no-class_inherits_from_params_class-check

Well, I’m not using puppet-lint directly, and puppet-lint is called by the Atom editor. Here’s how it can be disabled:

Edit ~/.atom/config.cson:

  "linter-puppet-lint":
    puppetLintArguments: "--no-autoloader_layout-check --no-class_inherits_from_params_class-check"
    puppetLintExecutablePath: "/usr/bin/puppet-lint"

Ref: http://puppet-lint.com/checks/class_inherits_from_params_class/